[OmniOS-discuss] Cloned Zones and Networking
Stephen Nelson-Smith
stephen at atalanta-systems.com
Fri Dec 14 05:33:39 EST 2012
Hi all,
I caught the tail end of someone on IRC discussing this a week or so
ago. I find myself trying to do something similar. Here's the
scenario:
# dladm create-vnic -l bge0 z2
# zonecfg -z z1 export | sed 's/z1/z2/g' | tee /tmp/z2.config
create -b
set zonepath=/zones/z2
set brand=ipkg
set autoboot=true
set limitpriv=default,dtrace_proc,dtrace_user
set ip-type=exclusive
add net
set physical=z2
end
# zoneadm -z z1 halt
# zonecfg -z z2 -f /tmp/z2.config
# zoneadm -z z2 clone z1
# zlogin z2
# ipadm create-addr -T static -a 10.1.1.102/24 z2/v4address
ipadm: Could not create address: Object not found
Workaround:
ifconfig plumb z2 && ifconfig z2 10.1.1.102 netmask 255.255.255.0
broadcast 10.1.1.255 up
It'd be good to not have to workaround.
S.
--
Stephen Nelson-Smith,
Founder, Principal Consultant,
Atalanta Systems Ltd,
Web: http://agilesysadmin.net
Twitter: @lordcope
Skype: atalanta.systems
Direct: +44 (0) 1329 550203
Mobile: +44 (0) 7917 101919
Atalanta Systems: The Agile Infrastructure Enablers
http://atalanta-systems.com
More information about the OmniOS-discuss
mailing list